Broadcom 802.11 Linux STA - Algunas Preguntas y Respuesta

Por leprosys en 8/05/2009 ,
Este es un post al cual he llamado así porque son preguntas que yo me hice alguna vez y muchos aún no saben algunas respuestas a las siguientes preguntas, espero les ayude:

¿Para que tipo de tarjetas es este driver?
Si tienes alguna de estas tarjetas el driver funcionara para ti (con lspci sabes que tarjeta tienes):
14e4:432b "Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller"
14e4:4329 "Broadcom Corporation BCM43XG"
14e4:4328 "Broadcom Corporation BCM4328 802.11a/b/g/n"
14e4:4315 "Broadcom Corporation BCM4312 802.11b/g"
14e4:4313 "Broadcom Corporation BCM4310 Ethernet Controller"
14e4:4312 "Broadcom Corporation BCM4312 802.11a/b/g"
14e4:4311 "Broadcom Corporation BCM4311 802.11b/g WLAN"

¿Es necesario compilar el driver?
Es necesario en aquellas distribuciones que no tienen el binario en sus repositorios al final les proporcionare el listado de distribuciones que cuentan con el binario en sus repositorios.

¿Es mejor tener el driver de los repositorios o compilarlo de las fuentes?
Da igual siempre que funcione, ahora bien si has compila tu propio kernel sabrás de antemano que esta clase de drivers hay que compilarlos ya que los binarios de los repositorios no tendrán efecto.

¿Aircrack es compatible con este driver?
Lastimosamente no, mi experiencia con mi tarjeta que es BCM4312 no solo con este driver no ha sido de lo mejor con aircrack,
Como dice en su pagina si usted tiene una tarjeta broadcom sera aceptada a menos que sea alguna de las siguientes:
  • PCI ID 14e4:4315
  • Wireless-N

¿Como se si mi tarjeta es alguna de las anteriores modelos?
con el comando
lspci -nn

NOTA: Actualmente funciona con b43-fwcutter, probado en Arch Linux y con el kernel 2.6.32.

¿El driver necesita parches?
El driver hasta la fecha soporta hasta la versión 2.6.32 sin parches, versiones mas viejas del driver necesitan parches.
Algunos parches para kernels recientes:
Kernel 2.6.29
Kernel 2.6.30

¿Como se llama el driver que esta en los repositorios de mi distribución?
Hace poco he logrado ver que algunas distribuciones agregaron a sus repositorios este driver.
Las siguientes distribuciones son las que he logrado conseguir información de que cuentan con el driver en los repositorios:

Nota:
  • Algunas distribuciones necesitan mas intervención del usuario para funcionar aparte de las sabidas Gentoo y Arch Linux.
  • En Debian solo esta disponible para squezee y sid, además que necesita de la instalación de module-assistant.
  • En openSUSE hay que instalar un paquete adicional que lo encuentran en packman también correspondiente a su kernel.
  • Fedora además cuenta con otras dos versiones del driver llamados kmod-wl y akmod-wl.
  • Mandriva no cuenta con binario, para mas info visitar el wiki.

Back Top